deepfacelab中文论坛

 找回密码
 立即注册
查看: 200|回复: 8

Linux报错TensorFlow解决办法(me版才会报错)

[复制链接]

58

主题

433

帖子

2491

积分

初级丹圣

Rank: 8Rank: 8

积分
2491
 楼主| 发表于 4 天前 | 显示全部楼层 |阅读模式
星级打分
  • 1
  • 2
  • 3
  • 4
  • 5
平均分:NAN  参与人数:0  我的评分:未评
本帖最后由 wwe456999 于 2023-1-25 14:49 编辑

该报错是me版才有,普通版的老哥请无视
应该是TensorFlow库那边更新了不知道啥,之前pip一键弄,会一直安装不同版本,直到安装到2.7.4才兼容,浪费几分钟但是还是能行的,今天开始彻底不行了。
正题来了,me版的requirements-cuda.txt里面的TensorFlow-gpu是没有写版本号的,我们手动编辑,后面直接加上==2.7.4,就这么简单,应该是更新了不知道啥,导致以前的版本直接报错而不是一直安装到兼容的版本为止
IMG_20230125_115341.jpg
回复

使用道具 举报

4

主题

151

帖子

779

积分

高级丹师

Rank: 5Rank: 5

积分
779
发表于 4 天前 | 显示全部楼层
你可以看看你安装的路径
回复 支持 反对

使用道具 举报

58

主题

433

帖子

2491

积分

初级丹圣

Rank: 8Rank: 8

积分
2491
 楼主| 发表于 4 天前 | 显示全部楼层
feng7902 发表于 2023-1-25 12:36
你可以看看你安装的路径

不关路径事的,几个月都没出过错,我也不会去动他
回复 支持 反对

使用道具 举报

3

主题

24

帖子

455

积分

初级丹师

Rank: 3Rank: 3

积分
455
QQ
发表于 3 天前 | 显示全部楼层
带上你的nvidia-smi的截图,看一下你的驱动版本。不带版本号tensorflow-gpu默认安装最新版就行了。
回复 支持 反对

使用道具 举报

58

主题

433

帖子

2491

积分

初级丹圣

Rank: 8Rank: 8

积分
2491
 楼主| 发表于 3 天前 | 显示全部楼层
我的心是冰冰的 发表于 2023-1-26 14:33
带上你的nvidia-smi的截图,看一下你的驱动版本。不带版本号tensorflow-gpu默认安装最新版就行了。
...

他就是不支持最新的,只支持2.74或者更旧的版本
回复 支持 反对

使用道具 举报

3

主题

24

帖子

455

积分

初级丹师

Rank: 3Rank: 3

积分
455
QQ
发表于 3 天前 | 显示全部楼层
wwe456999 发表于 2023-1-26 18:10
他就是不支持最新的,只支持2.74或者更旧的版本

所以说让你带上你的驱动截图,我一直用的都是最新的。我之前有篇帖子上传过环境,还有你的硬件配置也没留。
回复 支持 反对

使用道具 举报

58

主题

433

帖子

2491

积分

初级丹圣

Rank: 8Rank: 8

积分
2491
 楼主| 发表于 前天 03:29 | 显示全部楼层
我的心是冰冰的 发表于 2023-1-26 18:53
所以说让你带上你的驱动截图,我一直用的都是最新的。我之前有篇帖子上传过环境,还有你的硬件配置也没留 ...

云服务器啊。。。。。。
回复 支持 反对

使用道具 举报

3

主题

24

帖子

455

积分

初级丹师

Rank: 3Rank: 3

积分
455
QQ
发表于 昨天 00:09 | 显示全部楼层
wwe456999 发表于 2023-1-27 03:29
云服务器啊。。。。。。

云服务器怎么了,看个NVIDIA驱动和配置跟是不是服务器有什么关系,建议你先看看这个帖子[url=DeepFaceLab在ubuntu上的配置教程 https://dfldata.xyz/forum.php?mod=viewthread&tid=7171 (出处: deepfacelab中文论坛)]DeepFaceLab在ubuntu上的配置教程 https://dfldata.xyz/forum.php?mod=viewthread&tid=7171 (出处: deepfacelab中文论坛)[/url],实在不会我劝你还是老老实实找个带win镜像的。
回复 支持 反对

使用道具 举报

58

主题

433

帖子

2491

积分

初级丹圣

Rank: 8Rank: 8

积分
2491
 楼主| 发表于 昨天 07:47 | 显示全部楼层
本帖最后由 wwe456999 于 2023-1-28 07:57 编辑
我的心是冰冰的 发表于 2023-1-28 00:09
云服务器怎么了,看个NVIDIA驱动和配置跟是不是服务器有什么关系,建议你先看看这个帖子https://dfldata. ...

我早解决了啊,。没看标题吗,况且我的是notebook,只有Linux自己开终端输入代码,没有win镜像。我的意思是现在要手动加TensorFlow版本号不然会报错,而我以前用了几个月都是不用加的
回复 支持 反对

使用道具 举报

QQ|Archiver|手机版|小黑屋|deepfacelab中文论坛 |网站地图

GMT+8, 2023-1-29 20:23 , Processed in 0.054833 second(s), 37 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表